Re: 'q' stops recording when you're searching

If you type 'qq' to begin recording to 'q', then /Sql, the 'q' stops the recording, and you get /Sl in the status bar.

One other thing: the behaviour of visual selection is still different from I'm used to with Vim. Select backwards and the last character is missed.



Re: 'q' stops recording when you're searching

rikkus, thanks for the feedback. I'll look into fixing the 'q' issue. Regarding visual selection, it emulates vim's "exclusive" selection mode, which is the only thing I knew when I first implemented it (I'm relatively a newcomer to vi/vim) thanks to having vim in windows use ":behave mswin" by default. I have since deactivated it and I like 'inclusive' more, but I haven't yet gotten around to implement the 'selection' :set option.


Re: 'q' stops recording when you're searching

Rik, I looked into it in detail and I think it works properly. What version of ViEmu are you using? According to my logs I implemented this back in March'06, so it must have been fine since the first public release of ViEmu 2.0. Won't you be using ViEmu 1.x, right? smile