Re: VIEmu disabled when debugging?

VIEmu 2.2.6, VisStudio 2005 Professional.

It appears VIEmu is disabled when running a program in the debugger.  I couldn't find a configuration setting for this; is this a limitation?


Re: VIEmu disabled when debugging?


The only think I can think of is that the debugger protects the text editor as "read-only", and this disables ViEmu. I've seen it happen with some .NET languages. If this is the case, you can fix it by going to Tools|Options|ViEmu and checking the setting "Prevent VS2005+ warning 'Cannot Edit while Running'".

If that is not the problem, or if the proposed solution doesn't fix it, please go to Help|About, copy the contents there, and paste them back here. Also, please let me know what language and project type you are using, so that I can try to reproduce the problem.


  -- Jon


Re: VIEmu disabled when debugging?

Don't know how I overlooked that option...
That seems to have fixed it.


Re: VIEmu disabled when debugging?

Glad to hear that, no problem at all. Just post here if anything else acts up. Best regards,  -- Jon