Topic: Help with Enter key in command mode in VS HTML editor

I am stumped on this but don't see that anyone else is having the same problem, so I'm really just looking for any suggestions to help me track down this issue.

In the Visual Studio 2013 HTML (Razor) editor window, the Enter key is not registering in the command bar, such as when trying to save with :w or doing any sort of pattern searches.

I've tried disabling ReSharper and tried a new, blank MVC project with no difference.

I don't see this problem when using Visual Studio 2012 and everything else seems fine -- it is only in the Viemu command bar and only in this one editor that the Enter key seems not to be working.

Any suggestions appreciated.


Re: Help with Enter key in command mode in VS HTML editor

I finally tracked this down to incompatibility with the Web Essentials extension for Visual Studio (http://vswebessentials.com/). I am surprised if t his hasn't come up before because Web Essentials is a very popular project.

I tried various combinations of settings to try to resolve the issue. I thought I'd nailed it when I found the "Format HTML on Enter" option, but disabling that did not resolve the issue. I suppose it is possible that Web Essentials is still capturing the Enter keypress and just not doing the auto-formatting.

I hope to find a way to get Web Essentials and ViEmu to play nice together.