Re: Word & Outlook

I cannot seem to get ViEmuW working in Word and Outlook 2007, It is listed in the COM addins section, but I don't know which settings I must change to fix it.

If anyone has a tutorial for getting this to work I would be ever so grateful.


Re: Word & Outlook

Hi Tobi,

I'm installing Office 2007 in a new clean VM and will test it, to give you detailed instructions. I usually use Office 2003, but I tested it thoroughly in Office 2007 a few months ago, and several customers use it with Office 2007, so it must be some simple thing.

I'll get back to you as soon as the new install finishes and I can check all settings windows.




Re: Word & Outlook

Ok, I just finished installing Vista, Office 2k7, and ViEmu on it. It works fine in a totally clean installation. There are some things I see which would be worth checking in your installation:

- In Word, click on the “Office Button” (the large button on the top-left corner), and click the button “Word Options” at the bottom of the pop-up menu

- Select “Add-ins” on the left panel. “ViEmu for Word and Outlook” should appear in the first section of this list (“Active Application Add-ins”). The location for me is “C:\Program Files\ViEmuW\ViEmuW.dll”, and the type is “COM Add-in”. If you click on this item, the info below the list should show “Add-in: ViEmu for Word and Outlook”, “Publisher: <None>”, and the location I showed above.

- Now click “Trust Center” on the left panel, and then the “Trust center settings” button. Another settings window will appear.

- Click “Trusted Publishers”. There is none on my list.

- Click “Trusted Locations”. For me, this shows three locations in the section “User Locations”, and nothing in the section “Policy Locations”. The two checkboxes at the bottom (“Allow Trusted Locations on my network…” and “Disable all Trusted Locations…” are unchecked in my installation.

- Click “Add-ins” on the left-hand side panel. The three checkboxes (“Require Application Add-ins to be signed by Trusted Publisher”, “Disable notification for unsigned add-ins…” and “Disable all Application Add-ins…” are unchecked (the middle one is grayed out for me too.

- Click “ActiveX Settings”. The radio button selected for me is the third (“Prompt me before enabling..all controls with minimal restrictions”, and the “Safe Mode” checkbox is checked for me.

- Click “Macro Settings”. For me, the second radio button is the selected one (“Disable all macros with notification”, and the “Trust access to the VBA project object model” is unchecked.

Once you check this, can you let me know how the settings are for you, and whether changing any of these makes any difference? Possibly, you’ll need to close and restart Word for the settings to make effect.

Best regards,



Re: Word & Outlook

We followed up by email, it was none of the above options, but Tobi finally got it to work and kindly posted how he did it:


In case anyone else runs into the issue.