Re: Search special characters /č

I am a newbie in using Vim and tried ViEmu trial version 1.0.19. I wonder if ViEmu supports characters from Eastern Europe to be exact from Slovenia.

My problem is that searching /č does not work because ViEmu interprets č as é (sorry can't find the right code in reality it is e grave).

Any solution to this problem?



Well after using ViEmu for a while I found out that the same problem persist when I want to enter characters from code page 1250 (e.g. čćžšđ)

Last edited by zabig (2007-09-14 10:42:07)


Re: Search special characters /č

Hello Zabig,

Since ViEmu has to handle keyboard input at a quite low level, there have been a few issues with international keyboard layouts. I have fixed most of them by now (at least with Russian, Swedish, Icelandic, Spanish and Japanese layouts so far), but there is probably something remaining.

In order to reproduce this and be able to fix it, I'd need you to tell me exactly what keyboard layout you have configured (to configure it myself), and what keypress combinations you are using to get those characters. Combinations using AltGr have been specially nasty so far, but please let me know what you are using.

I'm out of the office until mid next week, so I might be able to fix this before that, but possibly I won't be able to until Thursday or Friday. Apologies.

Best regards and thanks for letting me know,

  - Jon


Re: Search special characters /č


Thanks for your fast response!

My regional settings on my MS WinXP
- Input language
- Keyboard layout (link)
are set to Slovenian.

Hope this info will help!

Until I uninstalled ViEmu from system characters čšžđ didn't work  in MS Word (I guess also because of low level handling). I expected that I could get those characters if I disabled ViEmu.


Re: Search special characters /č

Thanks zabig, I'll install that set up and let you know what I find out. It should be fixed shortly in a new ViEmu build.


  - Jon


Re: Search special characters /č

Hi Zabig,

After a long debugging session, I think I got what the problem was. I have fixed it and uploaded a new ViEmu/Word&Outlook build, 1.0.22:


Before installing this one, you need to manually uninstall the previous version of ViEmu/W&O if you have it installed.

It seems to fix the issue for me (with both Polish & Slovenian input systems), but please check it out and let me know.


  - Jon


Re: Search special characters /č

It works great with all the special characters we use in Slovenia!

Thanks again


Re: Search special characters /č

Great to know! Thanks.


Re: Search special characters /č

After another short test session I discovered that search function ( /č )  has the same problem: instead of searching for čćžžšđ it searches for some other characters!



Re: Search special characters /č

Hi zabig,

Indeed, you are right. It seems in 1.0.22 I only fixed being able to *type* those chars (and didn't realize the problem also happened when searching). I'm looking into it and I'll get back to you as soon as I have some news.


  - Jon


Re: Search special characters /č

Ok, I think I got it. I have switched the way I use for message hooking from ANSI to Unicode and that seems to fix it. Actually, "è" in code page 1252 is 0xE8, the same as "č" in code page 1250.

I've built & uploaded 1.0.23 with this fix. You need to manually remove the previous version before installing this one:


Let me know how it works for you.


  - Jon


Re: Search special characters /č

Now the searching for that characters works!

Great and thanks!


Re: Search special characters /č

Great to know, let me know if anything else acts up.