Re: ViemuWO trial with word 2003

I have word 2003 which came preinstalled with my vista laptop. I tried installing viemuwo, but nothing shows up after I open up a doc file.
I do not see the vi modes anywhere or any additional toolbars.   I am not sure what the problem is.

Thanks in advance for your help.


Re: ViemuWO trial with word 2003


This has happened a few times in the past with other customers, we've always ended up solving it by tweaking Word's settings. There are two main things I can think of:

- That ViEmu it isn’t getting loaded by Word for security lessons, or
- That it isn’t working because of a localized version of Word.

It's probably the first. Can you check security settings? In Word 2003, you can go to Tools|Options -> Security -> Macro security, and you can configure both the general security level (I have it set to medium) and there is a second tab called Trusted Publishers where I have checked “Trust all installed add-ins and templates”.

You will probably need to fully close Word AND Outlook, so that no instance of Word remains in memory, for the settings to take effect.

Please let me know if that helps. If not, we can start doing more detailed analysis.


  - Jon


Re: ViemuWO trial with word 2003

Thanks for the reply Jon.

However, I tried changing the security settings and that did not do the trick either. I am only running word, and  do not use or launch outlook - though that should not matter.

Any inputs on solving this issue are much awaited. I can't wait to try out viemu on word, given that I am vi junkie.


Re: ViemuWO trial with word 2003

Ok, let's try to track this down.

I have the intuition that it's some kind of security setting, but let's go in an orderly manner. From a previous tracking down of this issue by email with another customer, which ended up getting it to work just fine:


Stage 1:

First thing to, you should go to Word's "About" box. There is a "Disabled items" button. Click on it, and see whether "ViEmu" appears on it (you can reenable it there). This is potential problem & solution #1.

If that is not the problem, and it probably isn't, we should check whether ViEmu is correctly registered to be loaded. Can you check the following regitry key?


This key is the link to tell Word to load the addin. It should contain the following subkeys:

  Description: "ViEmu for Microsoft Word and Outlook"
  FriendlyName: "ViEmu for Word and Outlook"
  LoadBehavior: 0x00000003

If this is wrong somehow, please let me know. It would be weird though, I don't think this is the key.

If this is correct too, let's try to really check whether ViEmu is getting loaded into Word. For this purpose, we need an advanced process viewer. A good, free one is "Process Explorer" from SysInternals. Go to www.sysinternals.com, Process Utilities, Process Explorer, Download. Extract the contents of the ZIP file to some folder, and execute process explorer. Open Word. Now, click on the "Word" process on the top pane, and select the menu item "View | Lower Pane View | DLLS". The bottom pane will contain an alphabetically sorted list of DLLs. Go towards the end check whether ViEmuW.dll appears there. If it does, this is tricky. If it doesn't, then we know it hasn't really been loaded at all.


Stage 2:

Can you go, in Word, to Tools->Options->Security->Macro Security, and verify two things:

  "Security Level": I have it set to "Medium", which will warn you about macros and let you choose whether to load them.
  "Trusted Publishers": The checkbox "Trust all installed add-ins and templates" has to be enabled.

Any change to these settings requires a Word restart to actually make them work.

If I disable the second checkbox, and restart Word, ViEmu doesn't load at all, the same as you describe. Hopefully that is the problem in your system? Try to ensure the checkbox is checked and restart Word, to see what happens.


Stage 3:

Ok, so, next step. Let's move ViEmu from being a "system-wide add-in" to being a "per-user addin".

First of all, delete the following key with all its subkeys (it's the one we verified a while ago):


After this is done, let's add back ViEmu as a per-user add-in. To do so, save the .reg file contained in the ZIP file I am attaching and double click on it from wherever you saved it. It should ask you whether you want to add the information to the registry, to which you should answer yes. It will show a msgbox that it was added.

After this, launch Word. It's possible that it will now load (but I don't expect it to). But now it's configured differently. We can go to the Word "COM Add-Ins" interface and check whether ViEmu appears there.

Going to the COM Add-Ins dialog is not easy. This is the only way I've found to do it:

1) Right click on any tool bar in Word, and select "Customize"
2) In the dialog that pops up, make sure the "Commands" tab is selected, select the Category "Tools", and look for the "COM Add-Ins" command on the right-hand-side list
3) Drag the command to one of the active toolbars, it should add the button there (it's a text button that says "COM Add-Ins")
4) Click "Close" to exit this dialog

Now you can click on the "COM Add-Ins" button and a simple dialog will pop up. In my system, it shows an entry in the list called "ViEmu for Word and Outlook", and its checkbox is checked. What shows up on your system?


Can you please provide feedback on the above steps, so that we can try to narrow down the options?

I apologize for the hassles - thanks for being so patient and best regards,



Re: ViemuWO trial with word 2003

Thanks. But, issues remain.

Stage 1: Tried the About box, viemu was not showing up in the disabled items.
Looked for the registry key, the value contained was 0x2. I changed it to 0x3 and restarted. Nothing changed. it also had an extra sub key called REG_SZ.

SysInternals and process explorer does not show up viemu.dll. Thus, that is the problem - it is not getting loaded.

Security settings and checkbox are what you suggested. Nothing changes upon restart.

For stage 3, I do not see any zip files and therefore cannot proceed.

Pls advise me on taking things further. Thanks for your assistance.


Re: ViemuWO trial with word 2003

Oops, I have to dig for the zip file - I will email it to you tomorrow (apologies, I'm not at the office right now).

Thanks and best regards,



Re: ViemuWO trial with word 2003

Hi Jon,

Was wondering if you already sent the zip file, cos it does not show up thus far...



Re: ViemuWO trial with word 2003

Just sent it. Aplogies for the delay!


Re: ViemuWO trial with word 2003

Thanks - received the file.
Followed your instructions:
Under COM-Addins, it shows an entry in the list called "ViEmu for Word and Outlook" and it is *unchecked*.

Below, it gives a status message stating:
Location: C:\Program Files\ViEmuW\ViEmuW.dll
Load Behavior:Not loaded. A run time error occured during the loading of the COM-Addin

Please advise me on how to proceed further. Thanks. (ViEmu does not work yet....)

I did try checking the box, and restarted both word and my computer, but viemuw was still not loading.

Last edited by asdf (2007-11-26 02:32:03)


Re: ViemuWO trial with word 2003

Ok, it might have gotten disabled because of that very same reason. I'll send you an email shorted with instructions to download an instrumented build so that we can detect what's failing.

Apologies for the problems.


- Jon