Re: key binding

i have difficulties in understanding key binding mechanism of ViEmu.

currently, I have no item in both lists of keyboard dialog of ViEmu configuration.

And edit box of Keys scanned, with Ctrl, for clashing bindings: shows


this changes as i press buttons below, Apply, default, all.

With this configurations, i like to use ^F and ^B as vi commands not VS short-cut.

What should i do??


Re: key binding


The instructions to configure this are different for VS.NET 2003 or for VS2005/VS2008. Can you let me know which one you are using? Thanks!



Re: key binding

I am using VS2005.


Re: key binding

Ok, here are instructions on how to fix this under VS2005:

The source of the problem is that probably ViEmu performed its initial scan & keybinding removal without all the keybindings properly in place, resulting in an incomplete keybindings table (will be fixed in a future release).

This is the way to restore all VS2005 keybindings:

1) Disable ViEmu with Ctrl-Shift-Alt-V (so that there will be no interference afterwards)
2) Go to Tools|Import and Export Settings
3) Select "Reset all settings" and click "Next >"
4) Select a file where to save the current settings, or just "No, just reset settings" if there's nothing really you want to keep just in case
5) Choose the default settings type to which to reset all settings (I use VC++, but it's up to you)

This will restore all settings in VS2005. Now, if you go to a text edit window (ViEmu should keep on disabled), all standard VS2005 keybindings should work fine.

If this is the case, what you have to do now is instruct ViEmu to remove clashing keybindings and save them for automatic management. These are the steps to perform:

1) Go to Tools|Options|ViEmu->Keyboard. There should be a pretty long list on the right hand side list.
2) Click "Save and Remove" under the right hand side list (answer yes to the confirmation msgbox)

After this, you can go back to an edit window and press Ctrl-Shift-Alt-V. Everything should be fine now, regular non-clashing VS keybindings should work by default, and all of them should work when ViEmu is disabled. Ctrl-F, etc... will mean 'page down' with ViEmu enabled, and VS 'Find' with ViEmu disabled.

Please let me know if something doesn't match my description above, so that we can try to fix it.

Best regards,

  NGEDIT Software


Re: key binding

Thank you very much for the detailed explanation.

But still there is something wrong.

To restore all VS2005 settings worked fine, but even after that
there are no item at all in the both sides of lists.

I am using ViEmu2.1.17(installed as evaluation version and now registered)
and Korean language version of VS2005 and sp1.


Re: key binding

I re-installed newer version of ViEmu, but still same problem.
What I did is:

1) removed ViEmu in ControlPanel
2) restored VS2005 settings as you suggested.
3) installed ViEmu again.

even after this, still i cannot see any item in both sides of lists.


When I removed a key binding in the keybinding option of VS2005, say
removed ^F for find menu,
I could use ^F for keybinding for ViEmu.

But doing this for all bindings in concern, is not what i like to do.

Last edited by pkyoung (2008-01-17 00:57:57)


Re: key binding

It's a bit weird. Can you post or email me a screenshot of your Tools|Options|ViEmu->Keyboard dialog? I understand the lists are empty, but I'd also like to see the other entries in the dialog.




Re: key binding

since i don't know how to attatch the file to the posting,

i sent screenshots to the support  _at_ ngedit _dot_com.


Re: key binding

For anyone else watching this: we followed up by email, and it turns out the reason is that pkyoung is using the Korean localized version of Visual Studio. ViEmu already has provisions for German and Japanese, apart from the base US version, but not for Korean. As soon as I gather all the info, I will be preparing a new build of ViEmu/VS which recognizes keybindings spelled in Korean too. I'll announce it on the 'latest version' thread at the top of this forum.