Re: Couple issues with 2.2.1

Enter key behavior:
When I press enter in normal mode in a comment block, it acts as if I was in insert mode (e.g. a new line is inserted).  This also happens when I am entering a command with the cursor in a comment block so I can't do ':w' with my cursor in the comment block.  I am doing this in .cs files if that matters.

Also, when I enter a command with my cursor outside of a comment block, the command works, but the cursor is placed at the beginning of the line which is pretty annoying.

Visual mode:
This is a minor issue, but if I press 'v' and move to the left, the character under the cursor's original position is not selected.  This is not the case if I move to the right.  I have "Use Visual Studio selection for Visual Mode" unchecked.


Re: Couple issues with 2.2.1

I just tried using some older versions and I had to go back to version 2.1.26 to avoid the issues with the enter key.  It looks like 2.1.27 introduced the problem.


Re: Couple issues with 2.2.1

Hello Jason,

Thanks for the feedback. Indeed, the behavior of RETURN was changed in 2.1.27, in order to fix some issues with Visual Assist. It seems the new behavior works fine with C++ and others, but not with C#. I will have to address this somehow before the official 2.2 release.

What version of Visual Studio are you using? This could be helpful in order to reproduce it. Also, do you have any other 3rd party add-in installed? Going to Help|About, copying the contents there and pasting them back here would be the best to know exactly what you have installed.

About visual mode - actually, ViEmu implements vim's visual mode as if ":set selection=exclusive" has been done, instead of the more common "inclusive" mode. This is because vim in windows starts in exclusive mode by default, which is what I took as a reference. I only found out about "inclusive" afterwards. Fixing this (probably by implementing the 'selection' option) is planned for a future release.


  - Jon


Re: Couple issues with 2.2.1

Thanks for the quick response.

I am using Visual Studio 2005.  The only other add-in I have installed is ReSharper 4.


Re: Couple issues with 2.2.1

Thanks Jason, I'll try to install Resharper to repro it. It's very likely the cause. I'm sure it's possible to find some work-around. I'll post here.


Re: Couple issues with 2.2.1

Jason, I've been able to reproduce this (Resharper wasn't necessary, but Visual Assist had to be installed). I have also implemented and tested a fix, and it now seems to work fine in all environments and languages, no matter whether R# and/or Visual Assist X are installed or not.

Would you be so kind as to download, install and confirm that?


You needn't uninstall the previous version, this will upgrade it automatically.

This version also fixes a glitch with the cursor position after pasting a character-wise range, which had the logic backwards with regards to vim.

If everything is fine, I'll announce ViEmu/VS and ViEmu/SQL 2.2.3 and get on with finishing the new ViEmu/W&O 1.5.


  - Jon


Re: Couple issues with 2.2.1

I just installed 2.2.3, but it has the same problem.

To verify that 2.2.3 installed properly, I looked in the About window which lists "NGEDIT Software's ViEmu v2.2.3".  However, the product details show the following:

"ViEmu 2.1 - vi/vim editor emulation for Microsoft(TM) Visual Studio(TM)
(c) 2005-2008 NGEDIT Software (www.ngedit.com)"

I'm not sure if the 2.1 version just didn't get updated or if I have a botched install...


Re: Couple issues with 2.2.1

Thanks for finding a typo - the 2.1 is there by mistake. You actually have a a proper 2.2.3 installed.

So now, I haven't fixed the problem. I'm trying to reproduce it again. If I can't, I will get in touch with you to see if you can run an instrumented build and I can gather more info.


Re: Couple issues with 2.2.1

FYI, This is fixed for me in 2.2.5  C#, ReSharper, etc.. 

Thanks!  Couldn't get my hand to use j instead of <return>.


Re: Couple issues with 2.2.1

Thanks for the feedback mjblocko. I followed up with Jason by email and fixed it for 2.2.5, but forgot to post here. Hopefully everything is fine now!