Re: Escape - not working

Why does exit insert mode with <esc> not work? I must press <shift>-<esc> to exit insert mode.

I hope I didn't overlook anything in the manual.



Re: Escape - not working

Hello Dave,

That is pretty weird, but Escape handling in Visual Studio is indeed pretty complex. Can you check whether <Esc> is assigned to anything in Tools|Options|Keyboard? Also, what version of Visual Studio are you using, what language are you editing, and are there any other 3rd party plugins installed?

Please tell me as well which exact version of ViEmu you are using. You can check it in Tools|Options|ViEmu or in Help|About.

It should work right out of the box, and there hasn't been any case reported in which it didn't, but there might be some interaction I'm unaware of.




Re: Escape - not working

In case anyone is running into the same problem, we tracked it down by e-mail to be an interaction with VisualSVN or Developer Express' DXCore. Removing them fixed the issue. I plan to research it further in the future and possibly provide out-of-the-box compatibility logic in ViEmu (as done so far with Resharper, Visual Assist, etc...).