Re: Cant get rid of clashing keybinding


I cant get rid of the

907=Global::Ctrl+K, Ctrl+F

keybinding. I press Remove but it stays no matter how many times i press. I tried to manually remove the Ctrl+K, Ctrl+F binding from the VS keybindings (it's the FormatSelection by default), but no luck. Is this a bug?



Re: Cant get rid of clashing keybinding

When the command list shows a number instead of a command name, it's because Visual Studio isn't returning a command name, but an id (907 in this case). For some reason, keybindings of name-less commands cannot be removed. The API to access and modify keybindings in VS is quite unreliable.

Can you detail what VS version you are using, and what base keyboard set you are using? This could help in trying to address the problem.

  - Jon


Re: Cant get rid of clashing keybinding

I use VS 2008 Team Edition. The keyboard is a Swedish one.

It works in SQL manager studio, but it uses different keymappings though.


Re: Cant get rid of clashing keybinding

When I asked about what "base keyboard" you are using, I was asking about which based VS keyboard layout you are using. If you go to Tools|Options|ViEmu -> Keyboard, you will see a field at the bottom left called "Current keyboard scheme", which will show it (it's actually a .vsk filename).

Doing Tools|Import and Export Settings|Reset all settings, and choosing a different base keyboard scheme could help with the issue. My VS2008 installation shows five options: "General Development", "Visual Basic", "Visual C#", "Visual C++" and "Web Development". With C++ selected, I haven't found the problem you describe above.

If you just want to get rid of the notification on start up, you can also uncheck the "Scan for clashing keybindings on startup" checkbox at the ViEmu keyboard settings dialog.

  - Jon