Re: Half enabled ViEmu in .config file

When editing .config (ex: Web.config) the ViEmu status bar doesn't show, and the editor is stuck in a hybrid normal/insert mode rendering editing very painful. If cannot fix quickly, at least provide a simple way to disable ViEmu for these file, because editing is painfull. Also, editing normal Xml file, which .config are, work fine.


Re: Half enabled ViEmu in .config file

It seemed to be a incompatibility with Visual Assist X. I uninstalled it for others reason and now it works!


Re: Half enabled ViEmu in .config file

Thanks for posting Olivier. That is very helpful. I will try to address it for the future, as Visual Assist needs special treatment, mainly for files where VA doesn't do anything.


Re: Half enabled ViEmu in .config file

I simply enabled Visual Assist for config files to regain my viEmu abilities. Not sure what sort of long term effects this will have but so far so good.

VAssistX -> Visual Assist X Options -> Projects -> File Handling -> Extensions to ignore:

remove ".config;"


Re: Half enabled ViEmu in .config file

The reason behind this problem is how ViEmu interacts with Visual Assist. For proper compatibility, ViEmu has to wait until VAX intercepts an editor window before intercepting it itself. This wait is done if VAX is detected to be present. But if VAX fails to intercept an editor window, ViEmu will be waiting forever, and thus it will not work.

I routinely add file types that VAX does not intercept to an internal "exclusion list", so that proper interaction is maintained. Of course, the proper fix would be to know whether VAX is going to intercept it or not, but there doesn't seem to be a way to do that.

I have taken note of this case, and I will look into removing ".config" files from VisualAssist compatibility.


Re: Half enabled ViEmu in .config file

I also have this issue ever since I started using ViEmu. I'm not using Visual Assist X.
I have ReSharper (5 and previously 4.x) and some additional plugin installed.
Can anyone confirm that ViEmu works well or does not work with ReSharper when editing *.config files?


Re: Half enabled ViEmu in .config file

Pete, I've tried locally and it works just fine (w/o any other 3rd party add-ins). Can you try to disable R# and see what happens? We'll investigate anyway to see if we can repro with R#.


Re: Half enabled ViEmu in .config file

Pete, I've tried editing *.config files with ViEmu and ReSharper installed and I don't see any issues. Can you give us more specific information on the problems you are having, so we can investigate further? Also, which version of ViEmu are you using?