Re: VS 2010: Cannot navigate Smart Tag options

If you have a missing reference or other compile error, a Smart Tag will show up under the broken code. You can press Ctrl+. to show the error correction options, but with ViEmu enabled, you can't use the arrows and enter key to navigate and choose an option. I have to use my mouse or disable ViEmu before using Ctrl+. as it is now.

I'm using VS 2010. I haven't verified this bug on 2008.


Re: VS 2010: Cannot navigate Smart Tag options

Is this with Resharper or some other 3rd party add-in, or with stock VS? What language are you using?

Apart from this, an easy fix for these cases, and also working for other more difficult ones like Intellisense, is to use AutoHotKey to map Alt-Arrows or something similar, as proposed by JP Boodhoo:



Re: VS 2010: Cannot navigate Smart Tag options

It's stock VS 2010, on Windows 7 if that matters. I've tried again in a C# project and it seems to works correctly there; it's broken in VB only. I'm surprised that it hasn't come up before, given that it's stock behavior for me. I do wonder if there's something else happening.

There are no alternative keyboard shortcuts for moving within the Smart Tag dialog, nor are there options to customize it, as far as I can tell. AHK could disable ViEmu for me, but I'd still have to manually re-enable it after selecting the fix in the dialog, since I could hit any number of keys to do it.


Re: VS 2010: Cannot navigate Smart Tag options

Ah ok, it's good to know it's with VB! That is probably the reason.

The way I suggested AHK be used is to map Alt-Up/Alt-Down to sending raw Up/Down to the app, which ViEmu wouldn't see. No enabling/disabling required!

We'll look into it and get back to you.