Re: beta 5 does not work

so, I just re-installed VS2010 at home (got rid of RC and downloaded the Professional Trial ) and then installed viemu beta 5.
I restarted VS:

I get the VIM license dialog, in which I CANNOT check the "Don't show" checkbox.

Clicked ok, and immediately got an exception dialog

Microsoft Visual Studio
Visual Studio has encountered an exception. This may be caused by an extension.

You can get more information by running the application together with the /log parameter on the command line, and then examining the file 'C:\Users\amol\AppData\Roaming\Microsoft\VisualStudio\10.0\ActivityLog.xml'.

Once I click past this, Vi keys do not work in the editor anyway.

This is bizarre, because I have beta5 at work, and it seems fine.


Re: beta 5 does not work

This is really weird. Had you run VS at least once before installing ViEmu? Just so that we may discard that as a casue...

Also, can you mail us the activitylog file? Please use support [at] symnum [dot] com.

We'll look into this during this week.


  -- Jon


Re: beta 5 does not work

yes, I did run VS before installing ViEmu. It was having to use the damn editor that made be realize I needed ViEmu :-)

Unfortunately, the problem seems to be gone once I uninstalled and re-installed the package.  If it recurs,I'll make sure I use /log.


Re: beta 5 does not work

spoke too soon. activity log has been emailed.


Re: beta 5 does not work

Jon, is this the same issue that I have that I emailed you about?

I still can't get any of the betas to install in VS2010.  The error I get is:

The 'ViEmuTen.ViEmuTenPackage, ViEmuTen, Version=, Culture=neutral, PublicKeyToken=null' package did not load correctly.


Re: beta 5 does not work

Amol, thanks. Arhughes, not sure. We have to look into this in detail.

Can you try Beta 6 just to make sure? I just released it now:



  -- Jon


Re: beta 5 does not work


1. ctrl-f binding is broken again.
2. If I search for a word by "#", and then hit '' to get back, it instead inserts a '.
3. :se nohlsearch does not turn off hlsearch, but instead inserts a completion string from VAX.


Re: beta 5 does not work

Hopefully these are all fixed in the latest official one, 2.5.7:


Let us know if not!

We are still working in other, different integration issues with Visual Assist, for the next release (2.5.8), due out in a few days to a few weeks.