Re: Bug: Up/Down arrow keys don't work in insert mode

I'm using the latest viemu plugin with VS2005 Pro and Visual Assist X. Whenever I enter insert mode and attempt to move up or down with the arrow keys, no change in cursor location is seen. I tried turning off Visual Assist in case there was a conflict, but it didn't help. Also, when the Intellisense window pops up and I'm in insert mode, I can't use the up/down arrow keys to scroll through the list of options, which is frustrating. Arrow keys work as expected when I am not in insert mode.  I'd like to purchase the full version, but this current behavior is a deal breaker. Any help would be appreciated. Thanks.



Re: Bug: Up/Down arrow keys don't work in insert mode


This is a bit weird, but I have an idea where it may come from. Could you do an experiment? Please disable ViEmu temporarily with Ctrl-Shift-Alt-V, and can you check whether bot arrow keys, Home, End, Delete, Backspace and Return work? It is possible that this is due to a problem in the initial scanning of ViEmu of the stock keybindings, in order to remove their assignments in case of conflict with ViEmu.

Can you also please go to Tools|Options|ViEmu->Keyboard, and let me know what sets of commands appear both on the left and right hand side lists? If my intuition is right, both lists will be empty.

The fix is fairly straightforward, but please let me know what you find out before I can give you the steps to follow. These problems will disappear when I implement in ViEmu for Visual Studio the new interception method I have implemented in ViEmu for Word&Outlook, which will happen in a future release of ViEmu.

Let me apologize for tha hassles too. I perfectly understand this is a deal breaker, but I think it will be easy to fix as soon as we have all the information. Thanks and best regards,



Re: Bug: Up/Down arrow keys don't work in insert mode

For the interest of other users, I'd like to add that we followed up by email and fixed it with the following instructions (it was the problem I thought it might have been):


The source of the problem is that probably ViEmu performed its initial scan & keybinding removal without all the keybindings properly in place, resulting in an incomplete keybindings table (will be fixed in a future release).

This is the way to restore all VS2005 keybindings:

1) Disable ViEmu with Ctrl-Shift-Alt-V (so that there will be no interference afterwards)
2) Go to Tools|Import and Export Settings
3) Select "Reset all settings" and click "Next >"
4) Select a file where to save the current settings, or just "No, just reset settings" if there's nothing really you want to keep just in case
5) Choose the default settings type to which to reset all settings (I use VC++, but it's up to you)

This will restore all settings in VS2005. Now, if you go to a text edit window (ViEmu should keep on disabled), arrows should work fine.

If this is the case, what you have to do now is instruct ViEmu to remove clashing keybindings and save them for automatic management. These are the steps to perform:

1) Go to Tools|Options|ViEmu->Keyboard. There should be a pretty long list on the right hand side list.
2) Click "Save and Remove" under the right hand side list (answer yes to the confirmation msgbox)

After this, you can go back to an edit window and press Ctrl-Shift-Alt-V. Everything should be fine now, and up/down should work in insert mode, both for cursor movement and for Intellisense autocompletion.

Please let me know if something doesn't match my description above, so that we can try to fix whatever the real problem is.

Best regards,

  NGEDIT Software


Once the interception method used in ViEmu/Word is brought to ViEmu/Visual Studio (for version 2.5 or 3.0), this problem won't happen any more, as keybindings won't need to be removed at all.