Re: Search as a displacement modifier (d/match) not working

   I'm using ViEmu for Visual Studio and having a strange problem. I want to delete until I reach a certain character or match, which can easily be done with c/match or d/match. Now, when I type d, I see it appear in the status bar, but when I type /, it just replace the d command and will do a simple search (/blah).

   Strangest thing, I know this feature is working as my coworkers use it... First, I thought it might my version that was outdated, so I updated from 2.0 to 2.1. It didn't fix it. A point that I thought might do the difference: I'm using a french keyboard setting in Windows. I tried switching to an English keyboard and it didn't do the trick...

   I'm using VS 2005 Pro SP1 on Win XP. My coworkers are still using SP0 (hehe, or whatever comes before sp1). That's the last thing I could think of... And I'm not willing to uninstall VS just to try it on the no sp1 as this install took away 2 hours of my life, which I will never get back.

   Any suggestion would be appreciated.

PS: Even with that not working, it's nice to have that Vi emulator for Visual Studio. Cheers for the person that came up with this idea. Saves me a lot of time.


Re: Search as a displacement modifier (d/match) not working

Hi elik,

I have tried it right now on both VS.NET 2003 and VS2005 "SP0", and it works fine. I don't have a VS2005-SP1 install right now, as I'm out of town and on my laptop, but I guess it should work the same.

One possible cause of confusion is that, when the slash is typed, the previous part of the command is not shown any more (that is, the 'd' or 'c' is hidden). The fact that the command was typed before the search is not apparent until pressing Return and triggering the command.

Can you describe the exact behavior you are seeing? For example, in a line containing "hello", with the cursor on the "h", typing "d" first shows it in the status line, typing "/" removes the "d" and shows a slash in the status line, typing "o" moves the cursor in a vertical line shape to the "o" and selects it, and pressing Return leaves just the "o" on the line.

Thanks for the kind comment, I did this because I missed this myself and I thought other people would appreciate it too! I'm starting up an independent software business, so all support is greatly appreciated.

Best regards,



Re: Search as a displacement modifier (d/match) not working

In case anyone's wondering, we followed up by email and pressing return was actually the only thing needed (so, no problem with SP1, which is good!).