Topic: Weird location behavior

I am in a file and search up for text that is not currently in view.
The found text is displayed on the first line of the screen.
I hit the letter k to move up one line.
The cursor does move up one line like expected.
The searched text is now moved to one line after the bottom of the screen and my cursor is on the bottom of the screen.

I think that is very weird behavior.  The behavior I would expect is that the text scrolls one line so the searched for text is on the second line displayed on the screen and the current line is still on the top.


Re: Weird location behavior

I see this behavior any time my cursor is at the top of the screen and I move up one line.


Re: Weird location behavior

Thanks for the report. Just a couple of questions in order to try to reproduce it:
Do you use ViEmu's or VS's search?
Do you have the 'Use VS selection for visual mode' ViEmu option active?


Re: Weird location behavior

I use VS selection for visual mode.
I use ViEmu's search.


Re: Weird location behavior

I sure hope you can figure this one out.  It is becomming quite the frustration with things jumping around all over the place.

Whenever the cursor is on the top line and I move up one line (using k) the cursor is moved to the bottom of the page and the line I moved to is also moved to the bottom.  The expected behavior is just to scroll one line of code.


Re: Weird location behavior

We're working on a new patch to fix this and other reported bugs, it's expected to be ready later this week. Sorry about this, if this gets too frustrating a work-around is to disable the 'use VS selection for visual mode' option. You can transform a ViEmu visual range into a Visual Studio selection with the gS command.


Re: Weird location behavior

Thanks for the update, I appreciate that.


Re: Weird location behavior

You are very welcome, and thanks for your patience.


Re: Weird location behavior

Jerry, this should also be fixed in release 3.0.6. Can you please confirm it? Sorry for the inconveniences, and thanks again for your patience.


Re: Weird location behavior

I grabbed 3.0.6 and, unfortunately, the behavior still exists.  I checked my viemu settings to verify that 3.0.6 did install and that is the version identified in the settings.  I wil email to a screen print of my settings.  Also, I am using ReSharper 7.0 with VS 2012 if that makes any difference.


Re: Weird location behavior

I just installed this in VS 2010 and tested it there and everything works correctly.  I only see the problem in VS 2012.


Re: Weird location behavior

Thanks for checking, Jerry, we'll test it in VS 2012.