Re: backspace in : mode

I'm new to vi, but is there a way to use backspace in the : mode? Right now if I push backspace in that mode it removes the character the cursor is on and puts me into insert mode. I'm not sure if that's a bug or not.


Re: backspace in : mode

It's weird. It should definitely erase in the command line. What VS version and what language are you using? What keyboard scheme? What other 3rd party add-ins are installed? All of those may be the cause. If you try editing a plain text file, that will also help remove some of the possible diagnostics.

  - Jon


Re: backspace in : mode

I just noticed it only happens with the sql file I'm editing. VS2008, I'm using the standard keyboard scheme, resharper and codekana.


Re: backspace in : mode

Ok, it makes sense that the SQL language service interferes with normal backspace processing. I'll have a look at this and hopefully find a fix or a stable workaround.

Meanwhile, you might be able to remove the keybinding of Edit.DeleteBackspace in Tools|Options|Keyboard as a temporary workaround (even if you remove the binding, Backspace should still work via ViEmu).