Topic: ViEmu on vs2010 loses focus after exiting insert mode

This is a very strange problem which is only happening on one system. I have ViEmu installed on a laptop and desktop for vs2010 and both were working fine until I had to re-build my desktop system. After reinstalling vs2010 (and SP1) and Resharper, dotCover, ProPowerTools and ViEmu (all of which were installed before) on the rebuilt system I have very strange behavior.

Upon starting vs2010 and opening a solution, I can navigate just fine. However, once I make any change in the editor and press Esc to exit insert mode, here is what happens:

- Insert mode is exited
- Everything looks okay so far
- Any non-control characters typed from this point on do not navigate or get inserted
- For each character typed, a number appears at the bottom next to "-- NORMAL --"
- For instance, if I press "j" 5 times to move down 5 lines, this is what it might look like:
  -- NORMAL --23456
- No matter what I type, the numbers count up to 9 and continue again with 0, 1, etc.
- The really bad part is that ViEmu interprets the numbers shown as a count, so if I follow with a RETURN, ViEmu assumes I wanted to do the RETURN action (Next line) for instance, 23,456 times given the example above.
- At this point vs2010 is so busy I can't do anything further.
- If I press ESC instead, the numbers clear (as does the count) and the process starts over again with further typing.

If I disable ViEmu, whether in this mode or not, everything works fine again except that I don't have ViEmu of course. Re-enabling ViEmu brings back the problem immediately.

Since this only happens on one machine (both are Windows 7, x64, Intel, all up to date) I don't know what to think about it. I am hoping you at least have some suggestion as to what direction I might look. Uninstalling and reinstalling vs2010 didn't help. Nor did uninstalling and reinstalling ViEmu. Nor did removing _viemurc.

Any help would be very appreciated. Thanks.


Re: ViEmu on vs2010 loses focus after exiting insert mode

Hi Tom,

I can't reproduce the "busy vs2010" issue, i follow your steps and works fine to me without any troubles in software perfomance

Do you have the same versions of Resharper and ViEmu in both machines with the same configuration?

What version of Resharper and ViEmu have you installed?



Re: ViEmu on vs2010 loses focus after exiting insert mode

I understand that you can't reproduce this. It happens for me on just one machine, but even after wiping and reinstalling windows and everything it still happens on that machine. Same (latest) versions of everything on both machines.

What I have noticed is that if I disable ViEmu, reset the keyboard to default and set up the Resharper key mapping (without ViEmu) then editing continues to work fine. It's only if I enable ViEmu, even without setting the ViEmu key mapping, that the problem occurs.

Is there any kind of debugging log I can turn on so ViEmu can track what's going on. I'd love to have ViEmu back. I'll be happy to help debug the problem.


Re: ViEmu on vs2010 loses focus after exiting insert mode

Hi Tom,

did you try if you have the same issue with older ViEmu Versions?

Anyway let us study the problem in deep, thanks



Re: ViEmu on vs2010 loses focus after exiting insert mode

Thank you for the suggestion. I had not tried it. Rolling back to version 2.5.7 seems (so far) to have resolved the issue. If I find otherwise I will repost here.

I would also like to point out an issue with uninstalling 2.5.14. I used the Control Panel and it said it was removed. However, upon trying to install 2.5.7 (or 2.5.14 again) I got a message saying that all of the programs already had this add-in installed. I removed "C:\Users\Tom\AppData\Local\Microsoft\VisualStudio\10.0\Extensions\Symnum Systems SLU" directory and then I was able to install again. It seems your removal process should also remove this directory.

For further help on the problem described above I thought I'd include an image of what I see once the problem starts happening. As I type, for instance, J or K to move the cursor, numbers count across the bottom as in this image:

ViEmu Count

If I were to press a control key (such as ENTER) then that command would execute 12,345 times in this case which means the count across the bottom is interpreted as a VI command count prefix. I hope this helps.

Last edited by tomservo3k (2011-06-04 20:25:33)


Re: ViEmu on vs2010 loses focus after exiting insert mode

I have additional information. I rolled back one version at a time until the problem finally went away. The highest version I can use is 2.5.9. This version has other issues that bother me, such as the fact that vs selection doesn't also do viemu selection (although the reverse is true). But it's better than not working at all for me like the 2.5.14 version.

Again, if there is anything I can do to debug this for you I'd be happy to try test versions with debug or whatever.



Re: ViEmu on vs2010 loses focus after exiting insert mode

Thanks to you, tom,  for the reports, we are working with the difference between versions to find the cause of the problem, but is not easy work, in any release there are solved many bugs and implemented new functions, we expect fixit fot the next ViEmu release.


Re: ViEmu on vs2010 loses focus after exiting insert mode

Well this whole situation has been frustrating but I found the problem. I do find it odd that it affects only certain programs, and in your case, only certain versions of the program, but here is the solution. I uninstalled Comcast Constant Guard. Apparently this new security product from Comcast cable messes with the system in unintended ways. I posted the issue to a hardware forum and someone else with a similar problem suggested this. My suggestion NEVER USE COMCAST CONSTANT GUARD.

Anyway, thanks for trying. Problem solved.


Re: ViEmu on vs2010 loses focus after exiting insert mode

Hi Tom,
That's sounds good.
Anyway we still working in the new ViEmu release fixing some compatibility issues.

Thanks again for your reports.