Re: viemu/sql and vista


I can't get viemu/sql to work on Vista RTM.  I had it working with sql server 2005 on Server 2003, but after I install it on Vista and attempt to open the management studio, I get the following error:


Please suggest what I can do to solve this -- I miss it greatly!



Re: viemu/sql and vista

I should mention that viEmu for Visual Studio 2005 works great!



Re: viemu/sql and vista

Randy, thank you for your kind comment. Indeed, neither ViEmu/VS nor ViEmu/SQL are compatible with Vista. I finally was able to install Vista a few days ago (had to upgrade my computer), and I know what it's due to. I plan to release a Vista-compatible version really soon.

Since I've already had a few requests, I'll try to prepare a maintenance build that works with it today or tomorrow.

I'll get back in touch with you later today.

Thanks and best regards,



Re: viemu/sql and vista

I've gotten ViEmu to work successfully on VS on several machines.  The trick I do is after installing, start up VS the first time as an administrator, shut-down and then restart as  the normal user.


Re: viemu/sql and vista

jared, thanks a lot for the tip! I didn't realize that would work. Actually, I won't be able to release a proper fix until December the 10th or so, so the workaround is the only chance by now.

This might work with ViEmu/SQL, but it probably won't, as the integration hooks in the registry are completely different. Running the installer itself as an administrator may fix that part.

I apologize for the problems, I've jumped a bit late on to the Vista bandwagon.




Re: viemu/sql and vista

Found the problem -- and it might not be related to vista.  Note that I have the user account control (fake admin) feature turned off in Vista (incompatible with Infragistics install).

I ran sqlwb.exe inside windbg.exe, and saw that it was picking up a copy of msvcr71.dll from my Trillian install (?!).  I noticed that ViEmuSQL includes a copy of msvcr71.dll, so I wondered if it was necessary to have the right one.

I made a copy of ViEmuSQL's msvcr71.dll called xsvcr71.dll (very important to keep filename the same length!), and modified viemusql.dll to reference this instead (vim edits binary files).

Now it works :-)



Re: viemu/sql and vista

OMG. I really need to look into this in detail. It really looks ugly. I'll let you know as soon as I can gather more info.

Best regards and thanks for the tip,



Re: viemu/sql and vista

I haven't been able to reproduce the problem mentioned by wilbur, but I have actually prepared new builds of ViEmu/VS and of ViEmu/SQL that work fine with Vista & UAC. Details here:


Thanks for your patience and for the workarounds provided by everyone!